Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
lonelyofiory
11.10.2020 23:50 •
Информатика
Кто знает какие надо подставить координаты в программе кумир чтобы нарисовать конверт с черепахи. если знаете то скажите как и какое число надо подставлять чтобы рисунок получился вас
Показать ответ
Ответ:
katy512
08.03.2021 05:34
1, 2)
Сначала надо разделить IP на байты, по 8 бит:
1 )11001100.11100010.10100110.01101001
2) 11011001.10100001.01100011.00111010
Теперь переводим каждый байт в десятичную сс, получаем:
1) 204.226.166.105
2) 217.161.99.58
3, 4)
Переведем каждый байт в двоичную сс:
3) 10111100.1011.11000010.100000
4) 11110000.1111.0.10
Добавим незначащие нули, чтобы кол-во бит в каждом байте было равно восьми:
3) 10111100.00001011.11000010.00100000
4) 11110000.00001111.00000000.00000010
Уберем точки:
3) 10111100000010111100001000100000
4) 11110000000011110000000000000010
0,0
(0 оценок)
Ответ:
Leroy1234567
18.11.2022 02:52
#include <iostream>
#include <cstring>
using namespace std;
int main() {
int n,m;
cin >> n >> m;
int a[n][m], sn[n], sm[m]; //sn - сумма строк, sm - сумма столбцов
memset(sn, 0, n*sizeof(int));
memset(sm, 0, m*sizeof(int));
for(int i = 0; i < n; i++)
for(int j = 0; j < m; sn[i]+= a[i][j], sm[j]+= a[i][j], j++)
cin >> a[i][j];
cout << endl;
for(int i = 0; i < n; i++) cout << sn[i] << ' ';
cout << endl << endl;
for(int i = 0; i < m; i++) cout << sm[i] << ' ';
cout << endl << endl;
for(int i = 0; i < n; i++) {
for(int j = 0; j < m; j++)
cout << a[i][j] << ' ';
cout << endl;
}
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Artur242
28.12.2022 08:13
Здраствуйте наверно здесь нельзя о таком просить но всерогно. У кого телефон OnePlus 3 и выше (3t, 4 и т. д.) и вы не играете в фортнайт то мне с получением эмоции. Дело...
javajaaripo
09.06.2021 16:15
1. Вычисляемое в программе значение переменной m для входного данного 3 равно… For i:=1 to 4 do For j:=1 to 4 do If j mod 2 0 then a[i,j]:=i+j Else a[i,j]:= i-1; k:=strtoint(Edit1.text);...
lizayka2001
19.09.2021 12:36
Имеется таблица, состоящая из 3 строк и 3 столбцов. Чему будет равно значение элемента таблицы а[3,2] после выполнения фрагмента программы? k := 0; for i := 1 to 3 do for...
ulana207
11.11.2022 00:07
Логическая функция F задаётся выражением ¬a Ú (b Ù ¬c). Определите, какому столбцу таблицы истинности функции F соответствует каждая из переменных a, b, c. В ответе напишите...
sgymgjvb
31.03.2020 18:12
Что выведит программа, если a=5, b=3.#include using namespace std;int main(){int a, b, c;cin a;cin b;c = a * b;cout c...
svyatkin111
26.12.2022 02:37
Четыре ученика-актера готовятся к выступлению. три других ученика выступают в качестве гримеров. каждый ученик-актер должен быть загримирован и причесан, делать это можно...
kruglov428
26.12.2022 02:37
Вы движением робота и можете давать направление его движения с информационных сообщений : север , северо-восток , восток , юго-запад , запад , юго-восток , северо-запад...
olgakazakova20oy0u8c
08.06.2023 06:24
1) перечислите характеристики графа, имеющую структуру «сеть». постройте данную структуру. 2) для чего используется компьютерная графика в компьютерном моделировании?...
crisisd
23.10.2021 21:18
1. найдите правильно построенное отрицание суждения все воздушные шары зелѐные : все воздушные шары не зелѐные. не верно, что все воздушные шары зелѐные. докажите свою точку...
AnnaKeya
11.04.2022 14:16
Вводится последовательность из натуральных чисел. найти минимальный элемент среди нечётных. через if pascal...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Сначала надо разделить IP на байты, по 8 бит:
1 )11001100.11100010.10100110.01101001
2) 11011001.10100001.01100011.00111010
Теперь переводим каждый байт в десятичную сс, получаем:
1) 204.226.166.105
2) 217.161.99.58
3, 4)
Переведем каждый байт в двоичную сс:
3) 10111100.1011.11000010.100000
4) 11110000.1111.0.10
Добавим незначащие нули, чтобы кол-во бит в каждом байте было равно восьми:
3) 10111100.00001011.11000010.00100000
4) 11110000.00001111.00000000.00000010
Уберем точки:
3) 10111100000010111100001000100000
4) 11110000000011110000000000000010
#include <cstring>
using namespace std;
int main() {
int n,m;
cin >> n >> m;
int a[n][m], sn[n], sm[m]; //sn - сумма строк, sm - сумма столбцов
memset(sn, 0, n*sizeof(int));
memset(sm, 0, m*sizeof(int));
for(int i = 0; i < n; i++)
for(int j = 0; j < m; sn[i]+= a[i][j], sm[j]+= a[i][j], j++)
cin >> a[i][j];
cout << endl;
for(int i = 0; i < n; i++) cout << sn[i] << ' ';
cout << endl << endl;
for(int i = 0; i < m; i++) cout << sm[i] << ' ';
cout << endl << endl;
for(int i = 0; i < n; i++) {
for(int j = 0; j < m; j++)
cout << a[i][j] << ' ';
cout << endl;
}
}