Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
Arkadop
23.04.2020 16:15 •
Информатика
Масса каждого из 25 человек хранится в массиве людей, имеющих массу более 100 кг будем условно называть полными (известно,что есть по меньшей мере один такой человек). определите среднюю массу полных людей, и среднюю массу остальных людей
Показать ответ
Ответ:
apdemyanovozaif8
07.10.2020 21:40
//PascalABC.NET
//Версия 3.3, сборка 1627 (27.01.2018)
begin
var l:=ArrRandom(25,50,150); l.Println;
Writeln('Среднее полных-> ',l.Where(t->t>=100).Average:0:4);
Writeln('Среднее остальных-> ',l.Where(t->t<100).Average:0:4);
end.
Пример:
55 108 131 58 141 62 102 56 118 78 128 114 110 66 134 74 71 56 103 126 76 133 118 99 101
Среднее полных-> 119.0714
Среднее остальных-> 68.2727
0,0
(0 оценок)
Популярные вопросы: Информатика
cJKYSIRJH
19.03.2022 09:42
Задание 1 Во Какие из приведённых утверждений верны? Выберите несколько из 4 вариантов ответа: 1) a % b = b // a 2) math.cos (1) = math.cos (1 + 2 * math.pi) 3) a % b = a - (a // b)...
Dimasik333000
17.07.2021 12:21
Чему будет равно значение переменной «a» после выполнения этого цикла? i: =3; a: =12; while i 3 do begin a: =a+i; i: =i+1; end;...
долма1
28.10.2021 07:19
Система счисления - двоичная 1)переведите число 70 из десятичной в двоичную 2)переведите число 235 из десят. в двоичную 3)переведите число 11011 из двоичной в десятичную 4)переведите...
zska25
02.10.2021 21:30
6 I can understand instructions. Please do these things.1 Stand up6 Look at your teacher,2 Sit down.7 Pick up your pen.3 Open your book.8 Write your name.4 Read your book. 9 Put your...
Alexa2608
06.08.2021 12:07
ответить на вопросы по философии. 1. Мораль и нравственность как предмет философского анализа2. Философский смысл проблемы бытия3. Сознание, его происхождение и сущность...
elinashovhalova
08.08.2021 17:19
Напишите кратко информацию о твердых, жидких и газообразных телах и что общего между твёрдым и жидким, между газообразным и жидким и между твёрдым и газообразным...
ВикторияПан
27.12.2020 08:07
Число в рамке умножь на каждое число в столбце (заранее...
Маалинка1
07.02.2022 20:24
Определи, какое количество теплоты (в джоулях) пошло на нагревание от 2°C до 97°C оловянной заклёпки массой 0,19 кг. Удельная теплоёмкость олова равна 250 Дж/(кг·°C)....
ezdar04
23.07.2022 14:23
С какими странами россия воевала, а с какими была в союзнических отношениях в 16 веке?...
YanaKotsyuk
07.10.2020 07:05
Великому мыслителю Древнего Китая Конфуцию принадлежит следующее высказывание: «Три вещи никогда не возвращаются обратно — время, слово, возможность. Поэтому: не теряй времени, выбирай...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
//Версия 3.3, сборка 1627 (27.01.2018)
begin
var l:=ArrRandom(25,50,150); l.Println;
Writeln('Среднее полных-> ',l.Where(t->t>=100).Average:0:4);
Writeln('Среднее остальных-> ',l.Where(t->t<100).Average:0:4);
end.
Пример:
55 108 131 58 141 62 102 56 118 78 128 114 110 66 134 74 71 56 103 126 76 133 118 99 101
Среднее полных-> 119.0714
Среднее остальных-> 68.2727