В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
kmvkemerovo
kmvkemerovo
11.06.2020 07:06 •  Информатика

Массив содержит информацию об отметках по информатике 20 учащихся класса.Отметки вводятся с клавиатуры.Составьте программу ,которая вычисляет средний по предмету и количество учащихся с отметками выше среднего .

Показать ответ
Ответ:
тапочек6
тапочек6
01.01.2023 16:29

using System;

using System.Collections;

using System.Collections.Generic;

using System.Linq;

namespace CSLear

{

   partial class Program

   {

       static void Main(string[] args)

       {

           Student Лёха = new Student("Свотин", "Алексей", 21, "ПИ 2-3", new int[5] { 4, 5, 3, 5, 3, });

           Лёха.GetInfo();

           Console.WriteLine($"Отдельно выведенные оценки Лёхи: {Лёха.AverageMark}");

           Console.ReadKey();

       }

   }

   class Student

   {

       public string Surname { get; set; }

       public string Name { get; set; }

       public int Age { get; set; }

       public string Group { get; set; }

       public int[] Marks { get; set; }

       public double AverageMark => Marks.Average();

       public Student(string Surname, string Name, int Age, string Group, int[] MarkList)

       {

           this.Surname = Surname;

           this.Name = Name;

           this.Age = Age;

           this.Group = Group;

           Marks = MarkList;

       }

       public void GetInfo()

       {

           Console.WriteLine($"Студент: {Surname} {Name}\nГруппа: {Group}\nСредний : {AverageMark}");

       }

   }

}

Объяснение:

Да, в VS 2019 можно использовать кириллицу для наименования переменных.

0,0(0 оценок)
Ответ:
ttm105
ttm105
16.07.2022 04:53

--- Python 3.8.3 ---

RawCost = input()

#Запишем "Голые" цифры рублей и копеек в две переменные

RawRub, RawCop = map(int, RawCost.split('.'))

#Приведём значения цены в рублях и копейках в порядок, если пользователь ввёл какой-либо неадекват

Rub += RawCop // 100

Penny -= (RawCop // 100) * 100

#Распечатаем полученный результат в консоль

print(f'Cost: {Rub} Rubles, {Penny} Penny')

Программа учитывает, что пользователь может оказаться не сильно умным и ввести цену из разряда 59.615 (то есть "копеечная" часть цены явно больше одного рубля)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота