В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Непатриот
Непатриот
08.11.2021 16:20 •  Информатика

Меньше среднего.C++ Дан массив A из N элементов. Требуется найти и вывести количество элементов,
значение которых меньше среднего арифметического значения элементов массива.
Input
Со стандартного устройства ввода в первой строке вводится целое число
N (1 <= N <=1000) — количество элементов массива. Во второй строке через пробел
вводятся N целых чисел - элементы массива A (-1000 <= A i <= 1000).
Output
Требуется вывести целое число - количество искомых элементов. Выводить в конце
строки пробел не нужно.
Sample Input
5
2 4 6 10 8
Sample Output
2
Примечание
Среднеe арифметическое значение элементов массива =
(Сумма значений всех элементов массива) / (Количество элементов в массиве).
В примере среднеe арифметическое значение = (2 + 4 + 6 + 10 + 8) / 5 = 6.

Показать ответ
Ответ:
Солнцеголовик
Солнцеголовик
27.08.2021 13:23

#include <iostream>

using namespace std;

int main() {

   int N;

   cin >> N;

   int* arr = new int[N];

   int sum = 0;

   for (int i = 1; i <= N; ++i) {

       cin >> arr[i - 1];

       sum += arr[i - 1];

   }

   int count = 0;

   for (int i = 0; i < N; ++i) {

       if (arr[i] < (sum / N))

           ++count;

   }

   cout << count;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота