В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
prozorovamary23
prozorovamary23
18.04.2020 04:03 •  Информатика

На basic составить программу нахождения наибольшего общего делителя и наименьшего общего кратного 2-х натуральных чисел.(нок(а, в) = а*в / нод (а,

Показать ответ
Ответ:
64738248585884847
64738248585884847
14.01.2022 01:49

//Написал простейшую программу для наглядного примера. Суть в том, что ограничено число попыток ввода неправильного пароля

//attempts - количество попыток, counter - счетчик неудачных попыток


const

  attempts = 3;

  password = '12345';

   

var

  counter: integer;

  str: string;

   

begin

  counter := 0;

   

  repeat

     write('Введите пароль: ');

     readln(str);

     

     if not(str = password) then

     begin    

        counter := counter + 1;

        writeln('[неверный пароль] осталось попыток: ', attempts - counter);

        writeln();

     end;

         

     if (counter = attempts) then

     begin

        writeln('Попытки ввода закончились!');

        break;

     end;

   

  until (str = password);

   

  if (str = password) then

     writeln('Вы ввели правильный пароль!');

end.


Как ограничить количество попыток ввода в паскаль?
0,0(0 оценок)
Ответ:
Давид1111david
Давид1111david
24.04.2020 06:10

//В строку location введите расположение требуемого файла

//Если хотите задавать расположение файла в ходе работы программы, то нужно будет убрать const со строки location

//Язык C#


using System;

using System.IO;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           const string location = "E://Test//File.txt";

           try

           {

               Console.WriteLine("Количество чисел, которые не делятся на 3: " + ReadFile(location));

           }

           catch (Exception)

           {

               Console.WriteLine("Ошибка (файл недоступен, либо содержит некорректный формат данных)!");

           }

           

           finally

           {

               Console.ReadKey();

           }

       }

       static int ReadFile(string location)

       {

           int counter = 0;

           StreamReader fileReader = new StreamReader(location);

           while (!fileReader.EndOfStream)

           {

               string num = fileReader.ReadLine();

               if (Convert.ToInt32(num) % 3 != 0)

                   counter++;

           }

           return counter;

       }

   }

}


Дан файл, который содержит целые ненулевые числа, которые оканчиваются нулем. найти количество чисел
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота