На каждое задание нужно создать отдельный файл в Питоне и написать в нем программу. Все файлы сохранить в архив и отправить мне личным сообщением. В модуле re есть еще несколько функций для работы с регулярными выражениями. Одна из них – это split(pattern, string). Она работает также, как строковый метод split но делит принятую строку не по разделителю, а по шаблону.
Дан набор строк в которых могут содержаться числа в двоичной системе счисления:
'1 "Hey!" 10 "Stop that!" 11 "Your vest looks stupid" 100 101 110'
'1000 "Did you kick someone in the face today?" 1001 1010 "Will I be making dinner then?!" 1011 110'
'10000 "Nice Beard" 1111 "Are you wearing denim shorts?" 1110 1101'
''
1
Напишите функцию, которая принимает строку и возвращает сумму всех двоичных чисел, присутствующих в строке. Сумма должна быть в десятичной системе. Если в исходной строке чисел нет или передана не строка, то функция должна вернуть -1. (Для конвертации в десятичное число из строки используйте int(‘строка’, 2) здесь второй аргумент – это основание системы счисления из которой нужно провести преобразование)
Предположим, что существуют «чистые строки» - это строки, в которых есть только буквы и пробелы. Никаких других символов в них быть не должно. Написать программу, которая загрузит содержимое приложенного файла, «очистит» все строки, создаст файл Result.txt и запишет результат в этот файл.
Дана строка, в которой буква h встречается как минимум два раза. Разверните последовательность символов, заключенную между первым и последним появлением буквы h, в противоположном порядке.
Вход: In the hole in the ground there lived a hobbit
Выход: In th a devil ereht dnuorg eht ni eloh ehobbit
z:string[10];
x:string[2];
i,j,k,m: integer; //новые переменные
Begin
Write('введите строку текста - St');
Readln(St);
k:=0; //обнуляем на всякий случай
z:='0123456789';
i:=1;
for j:=1 to length(St) do //начало
begin;
for m:=1 to 10 do
if St[j]=z[m] then inc(k);
end;
if k=0 then
begin;
writeln('в тексте нет цифр');
exit;
end; //конец
while i<=length(st)-1 do
begin
x:=copy(st,I,2);
if (x[1]=x[2]) and (pos(x[1],z)<>0) then
begin
delete(st,i,2);
insert('две',st,i);
i:=i+1;
end;
i:=i+1;
end;
writeln('преобразованная строка ', st);
End.
Adsl- асинхронная технология передачи данных, т.е. скорость входа и выхода отличаются, причем зачастую довольно неплохо
Tcp/IP- протокол контроля доставки пакета и присвоения адреса IP
Http- протокол передачи данных для гипертекстовых документов
FTP - файловый протокол передачи
Pop - протокол получения электронной почты
SMTP - протокол отправки эл. сообщений
DTM - протокол динамической коммутации каналов