В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
furymalice
furymalice
05.02.2023 12:06 •  Информатика

На основании исходных данных необходимо написать программу и получить ответ. Рассматривается множество целых нечетных чисел, принадлежащих числовому отрезку
[-1000; 2000], которые делятся на 17 или 23 и не оканчиваются на 3 или 5.
Найдите количество таких чисел и максимальное из них. В ответе запишите два целых
числа: сначала количество, затем максимальное число,​

Показать ответ
Ответ:
hbkkb
hbkkb
20.11.2020 23:02

Объяснение:

Программа на Питоне:

a=[]

m=-1001

n=0

p=int(input('Сколько будет чисел: '))

print('Вводите числа:')

for i in range(p):

  a.append(int(input()))

for i in a:

  if ((i % 17)==0 or (i % 23)==0 ):

      s=str(i)

      if not(s[-1]=='3' or s[-1]=='5'):

          if i>m:

              m=i

          n+=1

print('Количество: ',n)

if n>0:

  print('Максимальное:',m)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота