В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
6Мицуки6
6Мицуки6
29.11.2022 20:07 •  Информатика

На основе алгоритма пирамидальной сортировки составить программу, которая проводит сортировку массива целых чисел.

Показать ответ
Ответ:
Атытцрьури
Атытцрьури
15.10.2020 13:58

язык программирования python

def heapify(nums, heap_size, root_index):  

   largest = root_index

   left_child = (2 * root_index) + 1

   right_child = (2 * root_index) + 2

   if left_child < heap_size and nums[left_child] > nums[largest]:

       largest = left_child

   if right_child < heap_size and nums[right_child] > nums[largest]:

       largest = right_child

   if largest != root_index:

       nums[root_index], nums[largest] = nums[largest], nums[root_index]

       heapify(nums, heap_size, largest)

def heap_sort(nums):  

   n = len(nums)

   for i in range(n, -1, -1):

       heapify(nums, n, i)

   for i in range(n - 1, 0, -1):

       nums[i], nums[0] = nums[0], nums[i]

       heapify(nums, i, 0)

list_of_nums = [int(item) for item in input('Введите элементы через пробел: ').split()]  

heap_sort(list_of_nums)  

print(list_of_nums)  

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота