В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Fantik14rus
Fantik14rus
25.04.2023 04:45 •  Информатика

На С++ написать программу Дано натуральное число. Определить, сколько раз в нём встречается первая цифра.

Показать ответ
Ответ:
nastia04102015
nastia04102015
11.07.2021 22:41

#include <iostream>

using namespace std;

 

int main()

{

   int N, N1, count=0;

   

   cout << "N="; cin >> N;

   

   N1=N;

   

   while (N>=10)  

   {  

       N/=10;

   }

   

   while (N1)  

   {

       if(N1%10==N) count++;

       N1/=10;

   }

   

   cout << "count=" << count << "\n";

   

system("pause");

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота