В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
ELiNa98653742
ELiNa98653742
07.02.2023 22:04 •  Информатика

На с++ составить программу, которая запрашивает у пользователя два целых числа и выводит сумму квадратов а^2+b^2 этих чисел. пример работы программы a=3 b=2 сумма квадратов равна 13.

Показать ответ
Ответ:
Nurik271100
Nurik271100
08.06.2020 19:33

#include <iostream>

#include <cmath>  // подключаем файлы с библиотекой для возведения в степень

using namespace std;

 

int main() {

   long long a, b;  // инициализируем 2 переменных типа long long

   cin >> a >> b;  // вводим числа

   cout << 1LL * (pow(a, 2) + pow(b, 2))  << endl;  // выводим результат

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота