В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

На вход программы подается количество вводимых чисел, а затем сами числа. Определить сколько вводимых чисел кратных 13. Вывести количество этих чисел.
2) На вход программы подается количество вводимых чисел, а затем сами числа. Числа положительные, не превышающие 100. Определить максимальное число в последовательности. Вывести это число.

Показать ответ
Ответ:
smokenmyr
smokenmyr
14.10.2020 17:23

1)

var

 a,i,count:integer;

begin

 readln(a);

 count:=0;

 for i:=1 to a do  

   begin

     readln(a);

     if a mod 13 = 0 then

       inc(count);

   end;

 writeln('Count: ',count);

end.

2)

var

 a,i,max:integer;

begin

 readln(a);

 for i:=1 to a do  

   begin

     repeat

       readln(a);

       if a>100 then

         writeln('Error.Repeat');

     until a<=100;

     if i = 1 then

       max:=a

         else

           if max < a then

             max:=a;

   end;

 writeln('Max: ',max);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота