В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
доминик13
доминик13
30.08.2021 13:15 •  Информатика

На языке Pascal напишите программу, которая моделирует полет мяча при r=33мм, m=150г, Vнулевое=20 м/с, ς=0,1 с (некоторый шаг).

Показать ответ
Ответ:
Ozoda5
Ozoda5
19.01.2020 19:19

using System;


class Program

{

private static int GetThird(int num)

{

var result = 0;

var kv = num * num;

if (num % 2 == 0)

{

for (var i = num / 2; i > 0; i--)

{

result += kv - i * 2 + 1;

}

for (var i = 0; i < num / 2; i++)

{

result += kv + i * 2 + 1;

}

}

else

{

for (var i = (num - 1) / 2; i > 0; i--)

{

result += kv - i * 2;

}

result += kv;

for (var i = 0; i < (num - 1) / 2; i++)

{

result += kv + i * 2 + 2;

}

}

return result;

}


//оптимизированное свое решение, коротко и ясно

private static int GetThirdOptimized(int num)

{

var result = 0;

var kv = num * num - num + 1;


for (var i = 0; i < num; i++)

{

result += kv + i * 2;

}


return result;

}


private static void Main()

{

Console.WriteLine("Введите натуральноe числo ");

var i = int.Parse(Console.ReadLine());

Console.WriteLine("{0}^3 = {1} = {2} = {3}", i, i * i * i, GetThird(i), GetThirdOptimized(i));

Console.Read();

}

}

0,0(0 оценок)
Ответ:
Zizosia
Zizosia
11.02.2023 17:27
if5                                              

program raf105;

uses robot;

begin

task('if5');

if (wallfromdown) or (wallfromup)

 then begin left; paint; right; right; paint; left;

 end;

if (wallfromleft) or (wallfromright)

 then begin up; paint; down; down; paint; up;

 end;

end.

if6                                              

program raf105;

uses robot;

begin

task('if6');

up;

if cellispainted

 then begin down; down; paint; end

 else begin down; down;

   if cellispainted

     then begin up; up; paint; end

     else begin up; left;

       if cellispainted

         then begin right; right; paint; end

         else paint;

     end;

 end;

end.

if7                                              

program raf105;

uses robot;

begin

task('if7');

if wallfromright and wallfromdown

 then begin up; left; paint; end;

if wallfromleft and wallfromdown

 then begin up; right; paint; end;

if wallfromup and wallfromleft

 then begin right; down; paint; end;

if wallfromup and wallfromright

 then begin down; left; paint; end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота