В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Xanuzbek
Xanuzbek
17.05.2022 05:01 •  Информатика

На завтра ! напишите программу, которая определяет полиндром четырехзначное число или нет. можно в паскале !

Показать ответ
Ответ:
nika1557
nika1557
10.06.2020 19:21

var n:integer;

BEGIN

  read(n);

  if (n > 9999 or n<1000) then

    writeln('Вы дурак')

  else  begin

     if (n mod 10 = n div 1000 and n mod 100 div 10 = n div 100 mod 10) then

        writeln('Полиндром')

     else writeln('Нет');

  end;

END.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота