В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
kamila274
kamila274
09.09.2021 06:07 •  Информатика

Написать блок-схему и программу табулирования функции на заданном промежутке с шагом 0.2 и построить график этой функции. Язык C#


Написать блок-схему и программу табулирования функции на заданном промежутке с шагом 0.2 и построить

Показать ответ
Ответ:
VovaMel2017
VovaMel2017
07.06.2022 19:42

№1

a = [int(input('Введите значение: ')) for _ in range(int(input('Введите кол-во значений: ')))]

for i in range(len(a)):

   print('индекс ', i, ', значение ', a[i], sep='')

№2

a = [int(input('Введите значение: ')) for _ in range(int(input('Введите кол-во значений: ')))]

a.reverse()

for i in range(len(a)):

   print('индекс ', i, ', значение ', a[i], sep='')

№3

import random

print([random.randrange(10, 1000) for _ in range(int(input('Введите кол-во покупок: ')))])

№4

import random

a = [random.randrange(10, 1000) for _ in range(int(input('Введите кол-во покупок: ')))]

print(a)

print('Выручка составляет', sum(a), 'рублей')

№5

import random

a = [random.randrange(10, 1000) for _ in range(int(input('Введите кол-во покупок: ')))]

print(a)

print('Выручка составляет', sum(a), 'рублей')

print('Сумма наибольшей покупки составляет', max(a), 'рублей')

print('Сумма наименьшей покупки составляет', min(a), 'рублей')

№6

import random

a = [random.randrange(1, 50) for _ in range(int(input('Введите кол-во покупок: ')))]

print('')

print('| Число | Сумма от 1 до числа |')

for i in range(len(a)):

   print('')

   print('|', a[i], ' | ', sum(range(1, a[i]+1)), ' |')

print('')

Тут можно поиграть с таблицей, чтобы было хорошо было видно, а значения верные.

№7

import random

a = [random.randrange(1, 100) for _ in range(random.randrange(10, 20))]

b = int(input('Введите ограничение: '))

q = []

print(a)

for i in a:

   if i < b:

       q += [i]

print(q)

0,0(0 оценок)
Ответ:
ilyasovazalina
ilyasovazalina
14.02.2021 15:17

(см. объяснение)

Объяснение:

(x\in D)\rightarrow((x\in C)\rightarrow(x\in A))=(x\notin D)\vee(x\notin C)\vee(x\in A)

Тогда:

(см. прикрепленный файл)

Получили, что A=[20;\;41].

Поэтому ответом будет 41-20=21.

Задание выполнено!

Комментарий:

Можно (и несложно), конечно, было решить это задание программным методом (все-таки предмет информатика), но по-моему здесь куда более простое аналитическое решение.

На всякий случай вот рабочий код:

##

var r: integer := 1001;

for b: integer := 10 to 95 do

 for e: integer := b+1 to 95 do

 begin

   var f: integer := 1;

   for x: integer := 1 to 1000 do

     if(((x in [20..95])<=((x in [10..41])<=(x in [b..e])))=false)

       then f:= 0;

   if((f=1) and (r>e-b))

       then r:= e-b;

 end;

print(r);


На числовой прямой даны два отрезка: C=[10;41] и D=[20;95]. Отрезок A таков, что формула (x∈D)→((x∈C
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота