В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Adelka715
Adelka715
09.08.2021 13:23 •  Информатика

Написать программу 80
учёные планируют участок для испытательного полигона. участок должен иметь форму прямоугольника a x b, а полигон должен иметь форму прямоугольника c x d. с точными значениями чисел a, b, c, d ученые не определились, однако известно следующее:
длины сторон a b c d должны быть натуральными числами и выражаться в километрах.
для безопасности эксперимента длина и ширина участка должны отличаться от значения x, то есть выполняется неравенства a≠ x, b≠x
участок будет огражден забором, а полигон должен полностью помещаться внутри участка, то есть должны выполняться следующие условия: a> c, b> d
площадь участка, не занятого полигоном, должна быть ровно n квадратных километров, то есть должны выполняться следующие условия: a⋅b - c⋅d = n
ученые хотят понять, сколько у них выбрать подходящие значения a b c d.
требуется написать программу, которая по заданным n и x определяет количество выбрать числа a b c d так, чтобы все описанные условия выполнялись.
формат входных данных
в первой строке ввода содержится число n - площадь свободного участка без полигона (1< = n < = 3000) *это знаки меньше либо равно если что*
во второй строке ввода содержится число x - запрещенная длина участка (0 < = x < = 3000) значение x = 0 означает, что ограничений на длины сторон нет (так как длины сторон должны быть натуральными силами и следовательно больше 0).
формат выходных данных
в единственной строке выведите количество выбрать числа a b c d и так, что все описанные условия выполняются.

только напишите в паскаль или каком нибудь другом языке программирования и запустите обязательно чтоб правильно !

Показать ответ
Ответ:
sashaloxas
sashaloxas
08.05.2023 04:48
While (tnum != 0)  //tnum, tden - числитель и знаменатель искомой                                    дроби
    {
        if (tnum < tden)
        {
            temp = tnum;
            tnum = tden;
            tden = temp;
        }
        tnum = tnum - tden;
    }
    gcd = tden;  //вычисляем наибольший общий делитель
    numerator = numerator / gcd;  //делим числитель и знаменатель на
                                                      НОД, получаем сокращенную дробь
    denominator = denominator / gcd;
0,0(0 оценок)
Ответ:
Любознайка09
Любознайка09
14.03.2022 05:07

//Обьявляем дополнительные переменные и главный массив, а также два дополнительных - они будут "половинками".

var

 a, b, c: array [1..100] of longint;

 i, min, n, j, t: longint;

begin

 //Читаем количество элементов в нашем массиве.

 readln(n);

 

 //Читаем массив.

 for i := 1 to n do read(a[i]);

 

 //Заполняем первую "половинку".

 for i := 1 to n div 2 do b[i] := a[i];

 

 //Заполняем вторую "половинку". Но раз это уже вторая "половинка" главного массива, то и

 //цикл теперь должен начинаться со второй части массива, а заканчиваться уже в его конце.

 for i := n div 2 + 1 to n do c[i - n div 2] := a[i];

 

 //Теперь отсортируем первую "половинку" методом выбора. Идея этого метода

 //основывается на том, что мы ищем минимальный среди неотсортированных элемент,

 //а затем аем его с тем, который стоит сразу после отсортированных.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if b[min] > b[j] then

       min := j;

   if min <> i then begin

     t := b[i];

     b[i] := b[min];

     b[min] := t;

   end;

 end;

 

 //Затем вторую точно также, только стоит обратить внимание на сравнения.

 //Так как надо отсортировать по убыванию, то теперь сравнение перед "swap"-ом

 //будет другим.

 for i := 1 to (n - 1) div 2 do

 begin

   min := i;

   for j := i + 1 to n div 2 do

     if c[min] < c[j] then

       min := j;

   if min <> i then begin

     t := c[i];

     c[i] := c[min];

     c[min] := t;

   end;

 end;

 

 //А теперь по очереди выводим готовые "половинки", не забывая ставить

 //пробел после вывода каждого элемента.

 for i := 1 to n div 2 do write(b[i], ' ');

 for i := 1 to n - n div 2 do write(c[i], ' ');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота