Написать программу дан размер файла в байтах используя операцию деления нацело найти количество полных киллобайтов которые занимают данный файл (1 килобайт = 1024байта)
/*некритично, но у тебя нет диалога с пользователем. неплохо бы предложить ему ввести данные. в коде нет пояснений. */ #include<iostream.h> #include<conio.h> #include<math.h> int main() { int b,a, x,y,z; cout<<"insert a"; cin>>a>>endl; cout<<"insert b"; cin>>b>>endl; cout<<"insert x"; cin>>x>>endl; //а что такое x, y, и z - вообще непонятно. И откуда q появилась? ты ее не //объявлял.
if ((a%5==0)&&(b%5==0)); { if ((x<y)&&(y<z)) {y=a*x-b; cout<<"y="<<y<<endl; } if ((y<x)&&(y<z)) {y=a*y-b; cout<<"y="<<y<<endl; } } else cout<<"a i b ne kratny 5"; getch(); return 0; }
Смотри. 1. Ни Климов, ни Ушаков не умеют играть ни на одном музыкальном инструменте. Следовательно, они не учителя музыки. 2. Учителя рисования и информатики в воскресенье уезжают на дачу к Михеенко. Следовательно, Михеенко не учитель рисования и информатики. 3. Жебин попросил учителя рисования написать картины с его изображением и изображением Климова. Следовательно, Жебин и Климов не учителя рисования. Из этого следует, что учитель рисования - Ушаков. 4. Учителя рисования и информатики в воскресенье уезжают на дачу к Михеенко. Раз учитель рисования Ушаков, а он не знаком с Климовым, значит Климов не учитель информатики, а учитель матеметики. Михеенко - учитель музыки, а Жебин учитель информатики.
*/
#include<iostream.h>
#include<conio.h>
#include<math.h>
int main()
{
int b,a, x,y,z;
cout<<"insert a"; cin>>a>>endl;
cout<<"insert b"; cin>>b>>endl;
cout<<"insert x"; cin>>x>>endl;
//а что такое x, y, и z - вообще непонятно. И откуда q появилась? ты ее не
//объявлял.
if ((a%5==0)&&(b%5==0));
{
if ((x<y)&&(y<z))
{y=a*x-b; cout<<"y="<<y<<endl; }
if ((y<x)&&(y<z))
{y=a*y-b; cout<<"y="<<y<<endl; }
}
else cout<<"a i b ne kratny 5";
getch();
return 0;
}