В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Kamikatze5
Kamikatze5
26.12.2022 21:40 •  Информатика

Написать программу для паскаль! , , ! дано натуральное число. установить, является ли последовательность его цифр, при просмотре их слева направо, по убыванию.

Показать ответ
Ответ:
Imfind
Imfind
05.10.2020 02:21
// PascalABC.NET 3.2, сборка 1370 от 24.12.2016
// Внимание! Если программа не работает, обновите версию!

begin;
  var s:=ReadInteger('n=').ToString;
  If s.Length<>(s.Distinct.Count) then Writeln('не является')
  else
    if s=s.ToCharArray.SortedDescending.JoinIntoString('')
    then Writeln('является') else Writeln('не является')
end.

Примеры
n= 9875431
является

n= 9753321
не является

n= 9763421
не является

Замечание: учтено, что упорядоченность должна быть по убыванию а не по невозрастанию. т.е. нельзя, чтобы попадались две одинаковые цифры.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота