В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Pavelteknik
Pavelteknik
24.02.2020 14:49 •  Информатика

Написать программу для следующей задачи: "В 2020 году буханка хлеба стоило n рублей, а в 2021 году хлеб подорожал на x%. Сколько стоит хлеб после повышения?"
(Загрузите скриншот программы написанный на онлайн платформе trinket.io)

Показать ответ
Ответ:
nastya200525
nastya200525
19.03.2021 02:14

1) 128

2) 16

3) 512

4) 32

Объяснение:

1) Количество пикселей 64*128=2⁶*2⁷=2¹³

128 цветов - это 2⁷

Значит, количество информации на растр 64 х 128 пикс х 128 цветов:

2¹³*2⁷=2²⁰ бит = 2¹⁷ байт (так как в 1 байте 8 бит, т.е. 2³ бит)

2¹⁷ байт = 2¹⁷÷2¹⁰=2⁷ КB=128 КB (т.к. 1 КB  = 2¹⁰ байт)

2) по аналогии считаем:

1024*128=2¹⁰*2⁷бит=2¹⁷бит=

=2¹⁷÷2³÷2¹⁰= 2⁴ КB = 16 КB

3) 512*256*32=2⁹*2⁸*2⁵=2²² бит =

=2²²÷2³÷2¹⁰= 2⁹ КB = 512 КB

4) 256*128*8=2⁸*2⁷*2³=2¹⁸ бит =

=2¹⁸÷2³÷2¹⁰= 2⁵ КB = 32 КB

Есть 2 замечания.

1 - к выложившему задание на сайт. Будтье внимательнее к единицам информации. В вашем вопросе есть ошибка. Следует писать не "КБ" - кириллицей, а "КB" - латиницей. Единицы информации "КБ" не существует. Есть КB - латиницей, то же, что и "Кбайт" - кириллицей и допускается указывать Кб вместо Кбайт.

2 - к авторам вопроса. Фраза "для хранения любого растрового изображения " некорректна, т.к. наиболее распространённые форматы сохранения растровой информации используют алгоритмы сжатия (некоторые даже без потери информации о цвете), которые уменьшают объём занимаемой растром информации в десятки раз. Более грамотно звучала бы фраза "для хранения несжатого растрового изображения". Идём ко дну, товарищи.

0,0(0 оценок)
Ответ:
Vikzza
Vikzza
18.04.2020 16:25

1.

program ll1;

var i, a: integer;

begin

i:=2;

a:=2;

writeln(a);

while i<=10 do

begin

a:=a*a;

i:=i+1;

writeln(a);

end;

end.

2.

program ll1;

var a, i, sum: integer;

ssum: real;

begin

i:=1;

sum:=0;

while i<=10 do

begin

i:=i+1;

readln(a);

sum:=sum+a;

end;

ssum:=sum/i;

if ssum<1000 then

writeln('Низкая цена');

end.

3.

program ll1;

var A: array[1..7] of integer;

i, pr: integer;

begin

Randomize;

for i:=1 to 7 do

begin

A[i]:=random(10)-5;

write(A[i], ' ');

if A[i] = 0 then A[i]:=1;

pr:=pr * A[i];

end;

writeln(pr);

end.

4.

program ll1;

begin

writeln(1*2*3*4*5*6 + 3*3*3*3*3*3);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота