В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Aknur221
Aknur221
15.01.2021 09:22 •  Информатика

Написать программу для вычисления y и z значения (на языке C/C++) ja - это если
citos gadijumos - в другом случае
(Перевод с латышского языка ja, citos gadijumos)


Написать программу для вычисления y и z значения (на языке C/C++) ja - это если citos gadijumos - в

Показать ответ
Ответ:
85Angel85
85Angel85
24.05.2022 08:29
Схема
1)Количество монет в куче равно 1?
1a) Да, то это фальшивая монета выход
1b) Нет перейти к 2
2) разделим кучу поровну. перейти к 3
3)Правая куча тяжелее левой?
3a) Да, отложить правую и вернуться в (1)
3b) Да, отложить левую и вернуться в (1)
Можно еще добавить условия в случае если ее там нет
-1) разделим кучу на две поровну. перейти к 0
0) Кучи равны?
0а) Да, Выход нет фальшивой маеты
0b)Нет, перейти к 3
1)Количество монет в куче равно 1?
1a) Да, то это фальшивая монета выход
1b) Нет перейти к 2
2) разделим кучу на две поровну. перейти к 3
3)Правая куча тяжелее левой?
3a) Да, отложить правую и вернуться в (1)
3b) Да, отложить левую и вернуться в (1) 
Все гениальное просто:)
0,0(0 оценок)
Ответ:
Куска
Куска
14.06.2022 21:27
Если на паскале сойдет, то лови...
Если от 11 и до 15, значит возраст должен быть >= 11, но <= 15 (больше или равно, меньше или равно), это можно сделать с оператора in, допустим age будет равен 13, тогда пишем так if (age in [от..до]). И дальше можем что нибудь делать с этим. Вот код:
begin
var age: integer; //Создаем переменную для хранения возраста
readln(age); //Читаем возраст
if (age in [11..15]) then writeln('Подросток') else writeln('Не подросток');//Подробнее опишу
end. 

Допустим: 
Ввод: 13;
Вывод: 'Подросток'

Ввод: 18
Вывод: 'Не подросток'
И так далее...

Если не трудно
нажми " " ;)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота