В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
dimas1410
dimas1410
02.04.2023 06:18 •  Информатика

Написать программу дробей к наименьшему общему знаменателю. пользователь вводит две дроби. программа приводит дроби к наименьшему общему знаменателю.

Показать ответ
Ответ:
Полина9111111
Полина9111111
01.10.2020 17:03
Нахождение НОК двух чисел, оформите под вашу задачу
var
 x, y: integer;
function NOD(x, y: integer): integer;
begin
if x<>0 then NOD:=NOD(y mod x, x)
else NOD:=y;
end;
function NOK(x, y: integer): integer;
begin
NOK:=(x div NOD(x,y))*y;
end;
begin
read(x, y);
write(NOK(x, y));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота