В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
olyaevdokimova
olyaevdokimova
05.11.2022 16:12 •  Информатика

Написать программу и начертить блок-схемы решения задач:
Дан массив вещественных чисел, состоящий из 10 элементов. Найти максимальный элемент массива.

Показать ответ
Ответ:
kristina1333313
kristina1333313
13.10.2020 09:52

попробуй это. Тут еще с нахождением его номера

var a:array[1..100] of real;

    i,imax,n:integer;    

max:real;

begin

write('N= ');

readln(n);

for i:=1 to n do     read(a[i]);

writeln('');

imax:=0;

max:=a[1];

for i:=1 to n do     if a[i]>max then

begin max:=a[i];imax:=i;

end;

writeln('max = ',a[imax],' nomer = ',imax);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота