В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
agentponomarev6
agentponomarev6
19.04.2020 21:56 •  Информатика

Написать программу, которая бы по введенному номеру единицы измерения (1- килограмм, 2- миллиграмм, 3- грамм, 4- тонна, 5- центнер) и массе m выдавала соответствующее значение массы в килограммах. выполнить в паскале

Показать ответ
Ответ:
wolfwithyou
wolfwithyou
21.08.2020 12:59
Program massa;var m, a: real;     begin       writeln('Введите массу.');       readln(m);       writeln('Введите единицу измерения массы. 1 - килограмм, 2 - миллиграмм, 3 - грамм, 4 - тонна, 5 - центнер.');       readln(a);       writeln('Введённое вами значение равно ');        if a=1 then write(m, ' килограмм.');        if a=2 then write(m/1000000, ' килограмм.');        if a=3 then write(m/1000, ' килограмм.');        if a=4 then write(m*1000, ' килограмм.');        if a=5 then write(m*100, ' килограмм.');      end.

меее, немного с окончаниями напортачила, но если надо, то можно просто до кг сократить и всё будет ок
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота