В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Deyzer777
Deyzer777
26.04.2021 20:31 •  Информатика

Написать программу, которая получает случайное целое типа int, выводит его двоичное представление на экран, выполняет преобразование в соответствии с вариантом (см. ниже), затем выводит на экран двоичное представление результата преобразования. № варианта пример 1 изменить порядок следования битов в числе на обратный 11010011  11001011 язык си

Показать ответ
Ответ:
lilianochka1
lilianochka1
02.10.2020 07:19
Void dvoich(int x1)   {  
srand (time(NULL));   
int i, b;       
long c = 0; 
x1 = rand();       
for(i=0;x1 > 0;i++)       {         
b = x1 % 2;      
x1 = (x1-b)/2;         
c += b * pow(10,i);     }    
printf("\nDvoichnoe chislo: %d",c);   }  
reverse(c.begin(), c.end());
printf("\nDvoichnoe obratnoe chislo: %d",c);
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота