В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
OLEGator800
OLEGator800
27.09.2021 11:16 •  Информатика

Написать программу, которая проверяет, находится ли введенное с клавиатуры число в массиве.

массив должен вводиться во время работы программы. (pascal abc)

Показать ответ
Ответ:
КрендельЙА
КрендельЙА
10.10.2020 19:45

const n=8;

var a: array[1..n] of integer;

c,i: integer;

f: boolean;

begin

f:=false;

writeln('введите массив из ',n,' элементов:');

for i:=1 to n do readln(a[i]);

write('введите число: ');

read(c);

for i:=1 to n do if a[i]=c then begin

f:=true;

break;

end;

if(f) then write('введенное число находится в массиве')

else write('введенное число не находится в массиве');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота