В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
FlexxZ000
FlexxZ000
13.05.2022 03:19 •  Информатика

Написать программу которая проверяет -является ли сумма цифр заданного трехзначного числа четным числом

Показать ответ
Ответ:
raisabarsegyan
raisabarsegyan
21.08.2020 12:26
C++
size_t sum(size_t val)
{
     static size_t temp = 0;
     if (val > 0) {
         sum(val / 10);
         temp += val % 10;
     }
     return temp;
}  
int main()
{
     (sum(123) % 2) == 0 ? cout << "True" : cout << "False";  
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота