В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
KisKris1605
KisKris1605
10.11.2020 08:36 •  Информатика

Написать программу, которая сортирует записи в файле f по алфавиту по фамилиям.

Показать ответ
Ответ:
Еваююююююююююю
Еваююююююююююю
08.10.2020 22:01

// PascalABC.NET

// Версия 3.4 сборка 1749 (18.08.2018)


begin

var (f, out) := (ReadAllLines('in.txt'), OpenWrite('in.txt'));

f.Select((t, i)-> (t.ToWords[0], i)).Sorted.ForEach(t -> begin Writeln(out, f[t[1]]) end);

out.Close;

end.


Файл, который использовал для проверки в приложении(совпадение с реальными именами - случайность).

Считывание и запись происходит в одном файле.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота