В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
niksustokarev
niksustokarev
30.09.2022 23:34 •  Информатика

Написать программу, которая спрашивает у пользователя число, после этого выводит строку типа: 2 компьютера. В зависимости от введенного числа, программа должна корректно подставлять окончание для слово компьютер Пример:

Ввод: Пользователь ввел число 12

Вывод: 12 компьютеров
(Код должен работать с любым числом)

Показать ответ
Ответ:
вввв31
вввв31
15.01.2022 23:20

n = int(input("введи число"))

if n%10== 1:

print(n,"компьютер")

elif (n%10==2 or n%10==3 or n%10==4):

print(n,"компьютера")

else:

print(n,"компьютеров")

0,0(0 оценок)
Ответ:
ayaulym10
ayaulym10
15.01.2022 23:20

Объяснение:

язык программирования (С++)

int main() {int a;cin>> a; if (a<4) {cout << a " компьютерa " ;}else {cout<< a"компьютеров"} return 0;}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота