В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
averianova1986
averianova1986
14.07.2022 04:50 •  Информатика

Написать программу, которая требует ввода времени дня и, в зависимости от введённого значения, желает доброго утра, доброго дня, доброго вечера или спокойной ночи. среда програмирования: pascal abc.net

Показать ответ
Ответ:
onion2
onion2
25.09.2020 20:50
Program blablsbls;
var
time: integer;
begin
writeln('Введите текущий час!')
readln(time);
if time >= 7 and time < 11 then writeln('Доброе утро!');
if time >= 11 and time < 18 then writeln('Добрый день!');
if time >= 18 and time < 24 then writeln('Добрый вечер!');
if time >= 0 and time < 7 then writeln('Спокойной ночи!');
end.

Как-то так, если мне память на счет синтаксиса не изменяет.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота