В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
frolikoffgrigory
frolikoffgrigory
08.03.2022 22:20 •  Информатика

Написать программу, которая вводит с клавиатуры двумерный массив из 54 случайных (random) целых чисел и выводит количество элементов равных , попробую дать как можно больше

Показать ответ
Ответ:
amusabekova
amusabekova
18.03.2023 07:14
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var a:=ArrRandom(ReadInteger('n='),1,99);
  a.Println;
  var k:=ReadInteger('k=');
  Writeln('Сумма чисел, кратных ',k,': ',
    a.Where(x->x mod k=0).Sum)
end.

Тестовое решение:
n= 18
45 17 36 15 65 17 97 44 49 43 60 51 66 72 18 55 71 85
k= 12
Сумма чисел, кратных 12: 168

// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var a:=ArrRandom(ReadInteger('n='),1,20);
  a.Println;
  a.Where((x,i)->x=i+1).Println
end.

Тестовое решение:
n= 16
17 2 1 14 20 19 10 3 9 15 14 4 2 7 2 16
2 9 16
0,0(0 оценок)
Ответ:
амаеру
амаеру
18.03.2023 07:14
1.
const n=20; 
var
  a:array[1..n] of integer;
  i,k,s:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(51)-25;
  Write(a[i]:4)
end;
writeln;
write('K = '); readln(k);
s:=0;
for i:=1 to n do 
 if a[i] mod k = 0 then s:=s+a[i];
Writeln('s = ',s);
end.

Пример:
Исходный массив:
18 -24 -4 -21 15 19 18 -16 -1 -8 7 -21 21 22 -24 -4 18 -16 24 4
K = 3
s = 24

2.
const n=10; 
var
  a:array[1..n] of integer;
  i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(11);
  Write(a[i]:4)
end;
writeln;
writeln('Выбранные элементы:');
for i:=1 to n do 
 if a[i]<=i then Write(a[i]:4) else write(' ':4);
Writeln;
end.

Пример:
Исходный массив:
   9   1   2   8   2   7   1  10   8   3
Выбранные элементы:
       1   2       2       1       8   3
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота