В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
мопс22
мопс22
02.06.2023 07:20 •  Информатика

Написать программу, которая вычисляет среднее арифметическое первых n членов последовательности 1, 3, 5, 7, …, n. Количество n задается во время работы программы.
Среди двухзначных чисел найдите и выведите на экран числа, сумма цифр которых делится на 13.

Показать ответ
Ответ:
джамшутик2005
джамшутик2005
13.10.2020 00:46

ответ:1, 3, 5, 7, ... - арифметическая прогрессия, в которой первый член a1=1 и разность d=7-5=5-3=3-1=2.

запишем формулу n члена прогрессии:

an=a1+d(n-1)=1+2n-2=2n-1, где n - номер члена последовательности.

Составляем программу:

var n,s,i: integer;

begin

readln(n);

s:=1;

for i:=2 to n do s:=s+2*i-1;

write('сумма: ',s);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота