В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
зайка584
зайка584
01.07.2020 22:15 •  Информатика

Написать программу, которая вычисляет значение выражения 10⋅sinx+|x4−x5|. Формат входных данных
Входной файл содержит число x. Считать, что вводимые значения x принадлежат области определения выражения.

Формат выходных данных
В выходной файл выведите ответ на поставленную задачу не менее чем с 4 знаками после десятичной точки.

Примеры:
Вход
1
Выход
8.4147

Показать ответ
Ответ:
саша3347
саша3347
26.04.2021 12:13

Код C#:

double x;

           Console.Write("x = ");

           x = Convert.ToInt32(Console.ReadLine());

           x = 10 * Math.Sin(x) + Math.Abs(x*4-x*5);

           Console.WriteLine("Конечный результат: x = {0:0.#####}", x);

           Console.ReadKey();

Код Pascal:

Var

x:real;

Begin

Readln(x);

x := 10* Sin(x)+ abs(x*4-x*5);

write('x = ', x);

end.

Объяснение:


Написать программу, которая вычисляет значение выражения 10⋅sinx+|x4−x5|. Формат входных данных Вход
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота