В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
slava98881
slava98881
26.05.2023 00:23 •  Информатика

Написать программу, которая запрашивает возраст и выводит сообщение (подросток или нет). будем считать возраст подростка от 11 лет до 15 лет.

Показать ответ
Ответ:
Куска
Куска
15.09.2020 23:18
Если на паскале сойдет, то лови...
Если от 11 и до 15, значит возраст должен быть >= 11, но <= 15 (больше или равно, меньше или равно), это можно сделать с оператора in, допустим age будет равен 13, тогда пишем так if (age in [от..до]). И дальше можем что нибудь делать с этим. Вот код:
begin
var age: integer; //Создаем переменную для хранения возраста
readln(age); //Читаем возраст
if (age in [11..15]) then writeln('Подросток') else writeln('Не подросток');//Подробнее опишу
end. 

Допустим: 
Ввод: 13;
Вывод: 'Подросток'

Ввод: 18
Вывод: 'Не подросток'
И так далее...

Если не трудно
нажми " " ;)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота