Написать программу на C# вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 1000 тенге, в 5% - если сумма больше 2000 тенге
Эти две функции выполняют абсолютно разные функции.
Функцию input() мы используем для ввода строки с клавиатуры, по дефолту тип принимаемого объекта у нас будет - str.
Функция print() используется для вывода значений переменных/текста, да и в целом объектов. Функция выводит все элементы, разделяя их значением sep, и завершает вывод значением end. (sep/end мы можем задать вручную)
Еще можно сказать, что эти две функции можно использовать в комбинации друг с другом, например мы хотим спросить у пользователя имя, а затем вывести на экран: "Привет, [имя пользователя]!", можем использовать вот такой код:
Эти две функции выполняют абсолютно разные функции.
Функцию input() мы используем для ввода строки с клавиатуры, по дефолту тип принимаемого объекта у нас будет - str.
Функция print() используется для вывода значений переменных/текста, да и в целом объектов. Функция выводит все элементы, разделяя их значением sep, и завершает вывод значением end. (sep/end мы можем задать вручную)
Еще можно сказать, что эти две функции можно использовать в комбинации друг с другом, например мы хотим спросить у пользователя имя, а затем вывести на экран: "Привет, [имя пользователя]!", можем использовать вот такой код:
print("Привет, "+input("Как тебя зовут? ")+"!")
program z1;
var a:integer;
begin
write('Введите шестизначное число: ');
readln(a);
if a div 1000 div 100 + a div 1000 mod 100 div 10 + a div 1000 mod 10 = a mod 1000 div 100 + a mod 1000 div 10 mod 10 + a mod 1000 mod 10
then write ('счастливый билет')
else write ('обычный билет')
end.
Объяснение:
Вводим число
Если сумма первых 3 цифр равна сумме последних 3 цифр, то билет счастливый, иначе обычный
a div 1000 - первые 3 цифры
a div 1000 div 100 - первая цифра первых 3 цифр
a div 1000 mod 100 div 10 - вторая цифра первых 3 цифр
a div 1000 mod 10 - третья цифра первых 3 цифр
a mod 1000 - последние 3 цифры
a mod 1000 div 100 - первая цифра последних 3 цифр
a mod 1000 div 10 mod 10 - вторая цифра последних 3 цифр
a mod 1000 mod 10 - третья цифра последних 3 цифр