В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
turdalievab
turdalievab
27.04.2020 15:59 •  Информатика

Написать программу на free pascale известен номер группы первокурсников и список студентов из этой группы, по заданной фамилии студента определить занимается ли он в данной группе и под каким номером находится в списке группы с использованием сортировки одномерных массивов

Показать ответ
Ответ:
radich16
radich16
03.10.2020 18:17
Считаем, что сначала вводится количество студентов, потом список студентов (по одному в строчке), потом фамилия нужного студента

var
ss: string;
s: array [1..100] of string;
n, i, j: integer;
begin
readln(n);
for i := 1 to n do
readln(s[i]);
for i := 1 to n -1 do
for j := 1 to n - 1 do
if s[j] > s[j + 1] then
begin
ss := s[j];
s[j] := s[j + 1];
s[j + 1] := ss;
end;
readln(ss);
j := 0;
for i := 1 to n do
if s[i] = ss then
j := i;
if j = 0 then
writeln('NO')
else
writeln('YES ', j);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота