В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Maria590986
Maria590986
27.12.2022 09:22 •  Информатика

НАПИСАТЬ ПРОГРАММУ НА Pascal Задача 1: Автобусные остановки
Автобусные остановки расположены через каждые K метров от начала улицы, то есть на расстоянии 0, K, 2K, 3K и т.д. метров от начала. Света от начала улицы N метров, после чего устала и захотела сесть на автобус. Определите, сколько метров нужно пройти Свете до ближайшей остановки.

Входные данные
Программа получает на вход два целых числа K и N, записанных в отдельных строках. 1 ≤ K ≤ 2×109, 1 ≤ N ≤ 2×109.

Выходные данные
Программа должна вывести одно целое число — расстояние до ближайшей остановки.

Система оценивания
Решение, правильно работающее только для случаев, когда числа K и N не превосходят 10000, будет оцениваться в

Показать ответ
Ответ:
elezavetkavtoray
elezavetkavtoray
28.11.2020 18:18

var

k,n,i:integer;

begin

readln(k,n);

i:=n mod k;

if i<=k div 2 then writeln(i)

  else writeln(abs(i-k));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота