В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
sem212
sem212
17.04.2022 19:50 •  Информатика

Написать программу на паскале которая печатает первую и последнюю цифру 4-х значного числа, сравнивает их и печатает какое из этих двух цифр больше

Показать ответ
Ответ:
egork9957
egork9957
07.10.2020 20:01
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var a:=ReadInteger('Введите число').ToString();
var (d1,d4):=(a[1].ToDigit(),a[4].ToDigit());
writeln('первая: ',d1,'; четвертая: ',d4);
if d1>d4 then write ('больше ',d1) else if d1<d4 then write('больше ',d4) else
write('цифры равны: ',d1);
end.
0,0(0 оценок)
Ответ:
ekhvalebo
ekhvalebo
07.10.2020 20:01
Var
x:integer;
begin
Read(x);
Writeln(x div 1000, ' ', x mod 10);
if x div 1000 > x mod 10 then Writeln(x div 1000, ' - больше');
if x div 1000 < x mod 10 then Writeln(x mod 10, ' - больше');
if x div 1000 = x mod 10 then Writeln('Они равны');
end.

Пример:
1234
1 4
4 - больше
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота