В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
alisa332
alisa332
17.08.2021 09:13 •  Информатика

Написать программу на питон
известны дневные и ночные температуры мая. определить дни, когда перепад
температур был максимальным.

Показать ответ
Ответ:
димасик138
димасик138
10.06.2022 04:14

я уже вроде отвечал на такой вопрос, нашел код, вот:

import datetime

info = datetime.datetime.now()

hours = info.hour

mins = info.minute

sec = info.second

print(hours,mins, sec)

a = []

if hours == 1 or hours == 21:

a.append(f'{hours} час')

elif hours % 10 == 2 or hours % 10 == 3 or hours % 10 == 4:

a.append(f'{hours} часа')

else:

a.append(f'{hours} часа')

if mins % 10 == 1:

a.append(f'{mins} минута')

elif mins % 10 == 2 or mins % 10 == 3 or mins % 10 == 4:

a.append(f'{mins} минуты')

else:

a.append(f'{mins} минут')

if sec % 10 == 1:

a.append(f'{sec} секунда')

elif sec % 10 == 2 or sec % 10 == 3 or sec % 10 == 4:

a.append(f'{sec} секунды')

else:

a.append(f'{sec} секунд')

print(*a)

думаю сможете сами всё это просто запихнуть в функцию и будет вам счастье)

Объяснение:

0,0(0 оценок)
Ответ:
lenyanikiforovp07x7k
lenyanikiforovp07x7k
23.01.2020 10:40

program z1;

uses GraphABC;

var t:integer;

begin

SetWindowWidth(400);

SetWindowHeight(400);

SetFontSize(15);

write('Введите показания температуры: ');

read(t);

write(t);

SetPenWidth(2);

if t<=0 then

begin

SetPenColor(clBlue);

Line (150,200,200,150);

Line (200,150,250,200);

Line (250,200,200,250);

Line (200,250,150,200);

FloodFill(200,200,clLightBlue);

Line (100,200,300,200);

Line (200,100,200,300);

Line (100,100,300,300);

Line (100,300,300,100)

end

else

begin

SetPenColor(clYellow);

Line (100,200,300,200);

Line (200,100,200,300);

Line (100,100,300,300);

Line (100,300,300,100);

SetBrushColor(clYellow);

FillCircle(200,200,50)

end

end.

Объяснение:

картинки


Алгоритмическая конструкция Нужно составить программу очень
Алгоритмическая конструкция Нужно составить программу очень
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота