В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
max697
max697
06.12.2020 10:56 •  Информатика

Написать программу на с++найти количество четных цифр заданного натурального числа n

Показать ответ
Ответ:
nastunya29
nastunya29
03.07.2020 19:27

#include <iostream>

#include <locale.h>

using namespace std;

int main()

{

setlocale(0, "Russian");

unsigned int n;

unsigned short int s = 0;

cout << "Введите натуральное число N:" << endl;

cin >> n;

do {

 if ((n % 10) % 2 == 0)

  s++;

}

while ((n /= 10) != 0);

cout << "Количество чётных цифр числа: " << s << endl;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота