В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Belka172
Belka172
04.06.2021 03:10 •  Информатика

Написать программу на вход которой подается 2 числа найти их произведение не используя умножение блок схема

Показать ответ
Ответ:
ThreeDragons
ThreeDragons
08.06.2020 00:52

import java.io.BufferedReader;

import java.io.InputStreamReader;

public class NewClass {

   public static void main(String[] args) throws Exception {

   BufferedReader reader = new BufferedReader(new InputStreamReader(System.in)); //поток ввода данных

   int a = Integer.parseInt(reader.readLine()); //вводим первое число

   int b = Integer.parseInt(reader.readLine()); //вводим второе число

   int result = b; //результат

   //здесь цикл сложения второго числа

       for (int i = 1; i < a; i++) {

           result += b;

       }

       //выводим результат в консоль

       System.out.println("Ваш ответ: " + result);

       reader.close();

   }

}

Объяснение:

написано на Java, не уточнили на каком ЯП надо программу написать..

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота