В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
dina2607
dina2607
21.10.2022 18:42 •  Информатика

Написать программу на языке c++. напишите программу, которая вводит натуральное число n и выводит первые n чётных натуральных чисел. входные данные: входная строка содержит единственное число – требуемое количество чисел n . выходные данные: программа должна вывести в одну строчку n первых чётных натуральных чисел, разделив их пробелами.

Показать ответ
Ответ:
mrskelet7
mrskelet7
06.10.2020 23:17
#include <iostream>
using namespace std;

int main()
{
    unsigned n;
    cin >> n;
    if (n > 0) {
        for (int i = 2; i <= n; i += 2) {
            cout << i << " ";
        }
    }
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота