В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
AIDA196
AIDA196
20.04.2020 18:47 •  Информатика

Написать программу на языке Паскаль, находящая сопротивление R проводника по известному напряжению (u) и силе тока (I). R=u/y

Показать ответ
Ответ:
radchukilia
radchukilia
20.03.2021 20:45

несложная динамика)

#include <iostream>

#include <vector>

#include <map>

#include <cmath>

#include <queue>

#include <set>

using namespace std;

#define int long long

const int MAXN = 100,MAXK = 100;

int d[MAXN], d0[MAXN];

void solve(int n, int k)

{

   d[1] = k-1;

   d0[0] = 0;

   for(int i = 2; i <= n; i++)

   {

       d[i] = (d[i-1]+d0[i-1])*(k-1);

       d0[i] = d[i-1];

   }

   cout << d[n] + d0[n];

}

signed main() {

   ios_base::sync_with_stdio(0);

   cin.tie(0);

   cout.tie(0);

   int n,k;

   cin >> n >> k;

   solve(n,k);

}

0,0(0 оценок)
Ответ:
reginasachtova
reginasachtova
05.07.2022 07:28

Системный блок — это элемент персонального компьютера, который защищает компоненты компьютера, находящиеся внутри, от механических повреждений и внешнего воздействия.

Блок – это частица-пазл, используемая для создания кода в Скретч. Блоки крепятся друг к другу с специальных выступов. Существуют блоки событий, команд, репортёры, логические репортёры или блоки конца скрипта. Они имеют свои внутренности и при попытке вставить туда что-то неподходящее, будет синтаксическая ошибка. Много блоков составляют скрипт.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота