В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Написать программу на языке с++. дано натурально число а в десятичной системе счисления. если все цифры числа а различные, то вывести на экран сообщение "да", иначе - сообщение "нет".

Показать ответ
Ответ:
yliana262626
yliana262626
04.10.2020 11:13
#include <iostream>
using namespace std;

int main()
{
    int a;
    int k[9];
    bool f = true;
    cout << "a = ", cin >> a, cout << "\n";
    for (int i=0; i<10; i++) k[i]=0;
    while (a>0){
    k[a % 10]++;
    a = a / 10;
    }
    for (int i=0; i<10; i++){
    if (k[i]>1) f = false;
    }
    if (f) cout << "Да" << "\n";
    else cout << "Нет" << "\n";
    return 0;
}

Пример:
a = 12523
Нет
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота