В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
tatgomer
tatgomer
09.04.2023 18:22 •  Информатика

Написать программу на языке с++(желательно в компиляторе shell c++)

заполнить массив случайными числами в интервале [-100; 100] и переставить все элементы так, чтобы все положительные элементы стояли в начале массива, а все отрицательные и нули - в конце массива. вычислите количество положительных элементов.

решите, надо!
заранее

Показать ответ
Ответ:
mariyasidorova1
mariyasidorova1
07.11.2022 15:15

1)

var

a: integer;

even,odd: byte;

begin

readln(a);

even := 0;

odd := 0;

while a > 0 do begin

 if (a mod 2) = 0 then

  even := even + 1

 else

  odd := odd + 1;

 a := a div 10;

end;

writeln('even: ', even);

writeln('odd: ', odd);

end.

2)

var

   n, m: longint;

   a: byte;

begin

   readln(n);

   m := 0;

   while n>0 do begin

       a := n mod 10;

       n := n div 10;

       m := m*10 + a;

   end;

   writeln(m);

readln;

end.

3)

var

   a,b,c,i,n: integer;

begin

   write('n = ');

   readln(n);

   a := 0;

   write(a,' ');

   b := 1;

   write(b,' ');

   for i:=3 to n do begin

       write(a+b,' ');

       c := b;

       b := a + b;

       a := c

   end;

readln

end.

Объяснение:


Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
0,0(0 оценок)
Ответ:
ЯСоваНоТупая
ЯСоваНоТупая
22.05.2020 09:25

4. выделите текст цвет которого требуется изменить.на вкладке главная в группе шрифт щелкните стрелку рядом с элементом цвет шрифта а затем выберите цвет.для быстрого форматирования текста можно использовать мини-панель инструментов с параметрами форматирования.

5.выделите текст или ячейки с текстом которые нужно изменить чтобы выделить весь текст в документе word нажмите клавишу CTRL+A.на вкладке главная в поле размер шрифта выберите нужный размер шрифта.

6.форматирование текста изменение размера шрифта положение относительно страницы начертание курсив жирный обычной и т.д. основная цель повышение читаемости и наглядности текста

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота