В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Diana15007
Diana15007
19.02.2022 08:17 •  Информатика

Написать программу Натуральное число из n цифр является число Армстронга, если

сумма его цифр возведенных в n-ую степень равна самому числу.

Получите все эти числа, состоящие из трех и четырех цифр (пример

1³ + 5³ + 3³ = 153).

Язык программирования - С

Показать ответ
Ответ:
Шишеа
Шишеа
30.08.2022 09:21

ответ: В реальной жизни выполнение всяких действий связано с расходом различных ресурсов: материалов, энергии и времени. Даже производя какие-либо записи, мы расходуем ресурсы (например, бумагу, чернила и время). Еще недавно некоторые задачи нельзя было решить из-за слишком большого числа необходимых для этого операций и слишком малой скорости их выполнения. Появление электронных вычислительных машин сделало такие задачи разрешимыми. Алгоритму в интуитивном смысле в книге противопоставляется алгоритм в математическом, или формальном смысле. В последнем случае считается, что понятие определено методами, принятыми в математике, и основывается либо на других понятиях, имеющих математическое определение, либо на первоначальных, описанных настолько четко, что их свойства могут быть приняты за аксиомы новой теории. Теорию алгоритмов, которой посвящена эта книга, мы называем содержательной в том смысле, что именно алгоритмы как таковые во всем их разнообразии являются ее предметом.

Объяснение:

0,0(0 оценок)
Ответ:
sofia2004417
sofia2004417
09.02.2022 17:21

{Free Pascal Compiler version 3.0.4+dfsg-23 [2019/11/25] for x86_64}

{Copyright (c) 1993-2017 by Florian Klaempfl and others}

{Target OS: Linux for x86-64}

program test;

Uses Math;

   

   const N = 15;

   

   var

       A : array[1..N] of integer;

       i, mx, k : integer;

   

begin

   Randomize;

   {Генерация и печать массива}

   for i := 1 to N do begin

       A[i] := Random(50);

       write(A[i], ' ');

       if A[i] mod 2 = 1 then mx := A[i]

       end;

   writeln;

   

   

   for i := 1 to N do

       if A[i] mod 2 = 1 then

           if A[i] < mx then begin

               mx := A[i];

               k := i

               end;

   writeln('Число - ', mx, ', позиция - ', k);

end.

Результат выполнения программы:


Написать код на Паскале для решения задачи. Дан массив из 15 целых чисел. В заданном массиве найти м
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота