Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
artem0395
29.01.2021 02:17 •
Информатика
Написать программу, определяющую сумму/количество элементов массива, значение которых больше 1 и меньше 5. на языке с++
Показать ответ
Ответ:
ВиолаВиолеттик
08.10.2020 07:06
#include <iostream>
#include <array>
#include <numeric>
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 4 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if (num > 1 && num < 5) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
Расулев
07.07.2021 10:27
Дана программа, вычисляющая значение выражения х=5с^2-d (a+b)/(b+c), допишите недостающие фрагменты программы Program ;___ a,b,c,d,x ;Begina:=1,5;b:=2;c:=3;d:=0,5;X:=;Writeln...
Andrianovnd
15.02.2020 21:49
При форматировании слов изменяется... А) размер символов В) отступ абзаца С) расстояние между строками Д) все...
kolika2016
03.12.2020 04:18
Проанализировав таблицу соотношений разрешения и диагонали экранов, выбрать только варианты сверх комфортных разрешений: 1. Разрешение (800*600)/диагональ 9 дюймов 2. Разрешение...
filinenok98
10.04.2021 19:56
Плачу много ! дано натуральное четырехзначное число n. a) проверить есть ли в записи числа три одинаковые цифры....
Andriuy2003
21.04.2021 16:49
Алгоритма:Разветвляющийся 1.3 Какой результат выведет компьютер при а=0, b=10?...
Мммаксим
16.12.2022 10:37
Чтобы вставить обычную сноску, используют комбинацию клавишеOCtrl+Alt +NOctri-Alt +DOCtri+Alt+FOctri+Alt +E...
aliceBRATSKAIA
21.03.2021 13:32
Для работы со сносками в текстовом процессоре Word применяется...
marsik261
07.04.2020 11:34
Найти объем углекислого газа который образуется при разложении 200г.карбоната если примеси в нем составляют 10%...
dianochka17dor
07.04.2020 11:34
Испраьте ошибки вид ошибки пример а) однородные именные части составного сказуемого употребляются в разных падежных формах. пример: этот человек был добрый, скромный, но...
JustTonight
07.04.2020 11:34
Напишіть невеликий твір-роздум на тему які проблеми дорослішання в чемерис порушив у повісті вітька+ ? дуже потрібно.. будь ласка дякую...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <array>
#include <numeric>
using namespace std;
const size_t N = 10;
int main()
{
size_t sum = 0;
array<int, N> a = { 1, 5, 9, 6, 3, 0, 1, 4, -2, 4 };
cout << "Count: ";
cout << accumulate(a.cbegin(), a.cend(), 0, [&sum](size_t count, const int
num) {
if (num > 1 && num < 5) {
++count;
sum += num;
}
return count;
});
cout << " Sum: " << sum << endl;
}