Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
ErkeSapieva
22.02.2021 12:41 •
Информатика
Написать программу pascal: найти сумму всех чисел с клавиатуры, кратных заданному числу a.
Показать ответ
Ответ:
konoki1982
30.06.2020 23:14
Program gt;
var n,a,i,s,q:integer;
begin
read(n);
read(a);
s:=0;
for i:=1 to n do
begin
read(q);
if(q mod a=0)then s:=s+q;
end;
writeln(s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Karina902
30.10.2021 06:24
Дан массив, содержащий 2016 положительных целых чисел, не превышающих 1000. необходимо найти и вывести максимальный из тех элементов этого массива, шеснадцатиричная запись...
danilfag
12.09.2021 03:00
Реферат на тему історія розвитку компютерної техніки. Або електронно вичислюванні машини на вибір або то або то.Дякую)...
Андрей12385
05.03.2020 22:02
1)Вы хотите работать с разрешением монитора 640 × 480 (K=W×H) пикселей, используя 16 цветов (N). В магазине продаются видеокарты с памятью 32 Кбайт, 64 Кбайт, 128 Кбайт,...
АннаКлимчук1997
11.12.2022 08:08
Из 40 кг свежих яблок получили 6 кг сушёных яблок. на сколько процентов уменьшилась масса яблок в результате сушки...
nazarborovichok
11.12.2022 08:08
Составить диалог миждуметиями и выделить не большой более 7-9 строчек...
полинадудка
11.12.2022 08:08
Начало царствование александру iii конспект...
bahriddinJoN2085
11.12.2022 08:08
Что облегчало, а что удерживало колонизацию африки европейцами?...
marialkahelp
11.12.2022 08:08
Як відмінюється словосполуення жоден учень...
Азрет2002
11.12.2022 08:08
Какие экологические проблемы есть в челябинске? как их ришают?...
karinabuchneva16
11.12.2022 08:08
Чему учит рассказ лобо? автор э. томпсон 98...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var n,a,i,s,q:integer;
begin
read(n);
read(a);
s:=0;
for i:=1 to n do
begin
read(q);
if(q mod a=0)then s:=s+q;
end;
writeln(s);
end.