Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Показать больше
Показать меньше
parenvpolotencp00o5i
21.01.2020 21:03 •
Информатика
Написать программу, распознающую по длинам сторон среди всех треугольников прямоугольный. если таковых нет, то вычислить величину угла с. (паскаль) с объяснением, если можно. заранее .
Показать ответ
Ответ:
vika3630551
31.08.2020 18:55
//искать угол будем по теореме косинусов
Program n1;
var x,y,z:real;
function arccos(x : real) : real; {это понадобится для теор. кос.}
begin
arccos := 2 * arctan(sqrt((1 - x) / (1 + x)));
end;
procedure ygl( a,b,c: real); {процедура для удобства}
var ga: real;
begin
ga:=arccos((sqr(a) + sqr(b) - sqr(c))/(2 * a* b)) * 180 / pi; {сама теор. кос.}
writeln('угол С= ',ga:5:2);
end;
begin
write('введите сторону а: ');
readln(x);
write('введите сторону b: ');
readln(y);
write('введите сторону c: ');
readln(z);
if(x>=y+z)or(y>=x+z)or(z>=x+y)then writeln('Это не треугольник')
else if x*x+y*y=z*z then {теорема пифагора}
writeln('Это прямоугольный треугольник')
else if (x*x+y*y>z*z)and(x*x+z*z>y*y)and(z*z+y*y>x*x)
then
begin
writeln('Это остроугольный треугольник');
ygl(x,y,z); {вызываем процедуру}
end
else
begin
writeln('Это тупоугольный треугольник');
ygl(x,y,z);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
mitaikooo
12.01.2021 04:00
, очень , схема по информатике, годовая оценка решается Отметьте на схеме значения сигналов на входе и выходе...
EvgeniyNou
05.12.2022 02:59
, ОЧЕНЬ НУЖНО РЕШИТЬ ЭТИ Программы на питоне...
oksakuvp01cde
22.11.2022 16:58
как описывается массив из трёх элементов, которые являются вещественными числами в блоке описания переменных? необходимых написать пример в общем виде...
73Женя91
24.11.2020 02:45
Решите задачу по информатике...
JUGGERNOUT
26.05.2022 23:22
Фирма, в которую вы устроились работать, получила новый компьютер со склада, с предустановленной windows 7 Компьютер предназначен для работы с 1С Предприятия, для работы с таблицами...
olena345678644
30.05.2023 10:24
Дан массив заменить все его элементы ., большие заданного N, этим числом. паскаль...
kaliyeva2006amina
24.02.2023 16:35
Необходимо описать только рекурсивную процедуру revers4(l), которая выводит цифры числа в обратном порядке....
karapyz32
11.02.2022 17:21
Какое значение имеет переменная : A) Var s,k: integer; Begin s :=0; for k := 5 to 10 s := s+10; writeln(s); End. B) Var s,k: integer; Begin s :=0; for k := 2 to 8 s := s+k; writeln(s);...
shrnv
08.01.2021 16:47
Какие тела относятся к телам вращения?...
Чикама
02.04.2022 20:56
Установи соответствие между форматами файлов и редакторами, с которых можно их открыть и редактировать. Количество соединений: 4 .cdr о универсальный векторный формат, Поддерживается...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
Program n1;
var x,y,z:real;
function arccos(x : real) : real; {это понадобится для теор. кос.}
begin
arccos := 2 * arctan(sqrt((1 - x) / (1 + x)));
end;
procedure ygl( a,b,c: real); {процедура для удобства}
var ga: real;
begin
ga:=arccos((sqr(a) + sqr(b) - sqr(c))/(2 * a* b)) * 180 / pi; {сама теор. кос.}
writeln('угол С= ',ga:5:2);
end;
begin
write('введите сторону а: ');
readln(x);
write('введите сторону b: ');
readln(y);
write('введите сторону c: ');
readln(z);
if(x>=y+z)or(y>=x+z)or(z>=x+y)then writeln('Это не треугольник')
else if x*x+y*y=z*z then {теорема пифагора}
writeln('Это прямоугольный треугольник')
else if (x*x+y*y>z*z)and(x*x+z*z>y*y)and(z*z+y*y>x*x)
then
begin
writeln('Это остроугольный треугольник');
ygl(x,y,z); {вызываем процедуру}
end
else
begin
writeln('Это тупоугольный треугольник');
ygl(x,y,z);
end;
end.