В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География

Написать программу, реализующую процедуры заказа и расчета его суммы в мини — пиццерии. В меню пиццерии предусмотрено 4 вида пиццы и три вида напитков.
Пользователю выводится меню (вначале пиццы, потом
напитки), содержащее код и название. Пользователь вводит
код желаемого продукта, после чего вводит количество единиц
данного продукта.
В пиццерии предусмотрены два вида скидок:
■ если общая сумма заказа более 50$, то размер скидки составляет 20% от суммы заказа;
■ каждая пятая пицца — в подарок;
■ для напитков с ценой более 2$, если количество в заказе более трех, то скидка 15% (только на напитки, а не на
весь заказ).
Вывести пользователю «чек» для оплаты в виде: название —
количество — цена. Итого к оплате.
Написать на языке C++.

Показать ответ
Ответ:
nonolo07
nonolo07
31.07.2022 04:16
#include <iostream>
#include <stdio.h>
using namespace std;

int main(){
    int y;
    cin>>y;
    y=y%12;
    switch (y){
           case 4:{cout<<"Mouse"; break;}
           case 5:{cout<<"Bull";break;}
           case 6:{cout<<"Tiger";break;}
           case 7:{cout<<"Rabbit";break;}
           case 8:{cout<<"Dragon";break;}
           case 9:{cout<<"Snake";break;}
           case 10:{cout<<"Horse";break;}
           case 11:{cout<<"Goat";break;}
           case 0:{cout<<"Monkey";break;}
           case 1:{cout<<"Cock";break;}
           case 2:{cout<<"Dog";break;}
           case 3:{cout<<"Pig";break;}
           }
    cin.get();
    cin.get();
    return 0;
}
0,0(0 оценок)
Ответ:

НОВОСТИ

ИСТОРИИ

ШКОЛА

СПУТНИК

ПРОЕКТЫ

КЫРГЫЗЧА

ЎЗБЕКЧА

Что такое коронавирус, и почему о нем все говорят?

От Камила Баймуратова -  25 января 2020

Facebook  Twitter  VK  Telegram

Уже несколько недель китайские власти пытаются сдержать рас опасного и ранее неизвестного вируса, обозначенного Всемирной организацией здравоохранения как «2019-nCoV» или «коронавирус Уханя». На сегодняшний день от болезни погиб 41 человек, насчитывается более 1300 случаев заражения.

Медработники доставляют инфицированных в больницу в Уханье 17 января. Фото: Getty Images, лицензия Creative Commons

Очагом рас атипичной пневмонии, вызванной новым типом коронавируса, стал город Ухань в провинции Хубэй, с населением более 11 млн человек.

Для того, чтобы остановить рас болезни, власти Китая 22 января закрыли Ухань на карантин. 23 января карантин был введен в городе Хуангана, с населением в 7 млн человек, позже еще 8 городов были закрыты – отменены все поезда и самолеты, а также внутригородской транспорт.

Несмотря на то, что сегодня, 25 января, в Китае отмечают Новый год, были отменены многие массовые праздничные мероприятия.

Почти все случаи заражения новым вирусом зафиксированы на территории Китая, однако заболевшие выявлены и в других странах, в том числе в Таиланде, Вьетнаме, Сингапуре, Японии, Малайзии, Южной Корее, Тайване, Непале, Франции, Соединенных Штатах и Австралии.

Более того, первые случаи заболевания коронавирусом 24 января уже были зафиксированы в Европе, власти Франции сообщили о двух заболевших — в Бордо и Париже.

По информации Всемирной организации здравоохранения, первые сообщения о вспышках неизвестного вируса в Китае появились 31 декабря 2019 года, однако первые симптомы у заболевших возникли еще раньше — 8 декабря 2019 года.

Коронавирус и Кыргызстан

По информации министерства здравоохранения, пока не было ни одного зарегистрированного случая заражения в Кыргызстане. Всех прибывающих из Китая граждан отправляют на дополнительную проверку целях недопущения завоза коронавируса.

Директор департамента профилактики заболеваний и экспертизы Минздрава Толо Исаков 22 января сообщил о том, что в Кыргызстане на всех пропускных пунктах на границе с Китаем в Ошской и Нарынской областях и в аэропорту «Манас» установлены тепловизоры для проверки на наличие коронавируса. Также термометрия работает в аэропорту Оша.

По его словам, тепловизоры могут на расстоянии определить людей с повышенной температурой и подозрением на инфекционные заболевания.

«Всемирная организация здравоохранения пока не вводит ограничительные меры ни в одной стране. Также еще точного заявления не было, отчего вирус передается. Сообщалось, что вирус передается от человека к человеку. Однако ВОЗ официального заявления не делала», – сказал он.

Исаков отметил, что во о вирусе «находится под контролем», а для врачей проводят дополнительные обучающие семинары о гриппе, ОРЗ, ОРВИ и коронавирусах.

Также 23 января в Министерстве здравоохранения встреча министра здравоохранения Космосбека Чолпонбаева с послом Китайской Народной Республики госпожой Ду Дэвэнь по ситуации с коронавирусом.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота