В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
murenko20061
murenko20061
21.05.2021 02:00 •  Информатика

Написать программу решения на языке паскаль: а)известно, что х кг шоколадных конфет стоит а рублей, а y кг ирисок стоит в рублей. определить, сколько стоит 1 кг шоколадных конфет, 1 кг ирисок, а также во сколько раз шоколадные конфеты дороже ирисок. б)дана длина ребра куба а. найти его объем и площадь поверхности

Показать ответ
Ответ:
cooldasha11042
cooldasha11042
22.07.2020 16:48
// Известно, что Х кг шоколадных конфет стоит А рублей,
// а Y кг ирисок стоит В рублей. Определить, сколько стоит 1 кг
// шоколадных конфет, 1 кг ирисок, а также во сколько раз шоколадные конфеты дороже ирисок.

var x,y,a,b: real;
begin
  writeln('Введите массу шоколадных конфет');
  readln (x);
  writeln('Введите сумму потраченную на покупку шоколадных конфет');
  readln (a);
  writeln('Введите массу ирисок');
  readln (y);
  writeln('Введите сумму потраченную на покупку ирисок');
  readln (b);
  writeln ('килограмм шоколадных конфет стоит ',(a/x):0:2,' рублей');//(a/x):0:2 - округряем до сотых)
  writeln ('килограмм ирисок стоит ',(b/y):0:2,' рублей');
  Writeln ('Шоколадные конфеты дороже ирисок в ',(a/x)/(b/y):0:1,' раз');// - округляем результат до десятых
 end.

//Дана длина ребра куба а. Найти его объем и площадь поверхности

Var a: real;
begin
  writeln ('введите длину ребра куба');
  readln (a);
  while a<0 do
    begin
      writeln ('вы ввели не допустимое значение попробуйте еще раз');
      writeln ('введите длину ребра куба');
      readln (a);
    end;
  writeln ('площадь куба равна ',a*a*6);
  writeln ('объем куба равен ',a*a*a);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота