В
Все
М
Математика
А
Английский язык
Х
Химия
Э
Экономика
П
Право
И
Информатика
У
Українська мова
Қ
Қазақ тiлi
О
ОБЖ
Н
Немецкий язык
Б
Беларуская мова
У
Українська література
М
Музыка
П
Психология
А
Алгебра
Л
Литература
Б
Биология
М
МХК
О
Окружающий мир
О
Обществознание
И
История
Г
Геометрия
Ф
Французский язык
Ф
Физика
Д
Другие предметы
Р
Русский язык
Г
География
Renatka96
Renatka96
27.01.2023 18:18 •  Информатика

Написать программу с использованием процедуры или функции. объявлен массив целых чисел. m размером 5х10. заполнить массив числами из промежутка [-20,20]. каждый элемент массива заменить его кубом. исходный и измененный массив вывести на экран. возведение в 3 степень организовать с функции или процедуры

Показать ответ
Ответ:
karinroy
karinroy
25.05.2020 21:29

type
  Mas = array [1..5, 1..10] of integer; //Объявляем тип массива

 

var
  m: Mas;  //Переменная типа массива
  i, j: integer;  //Переменные для цикла

 

procedure CubeMas(var m: Mas); //Процедура возведения в куб
var
  i, j: integer;  //Локальные переменные цикла в процедуре

begin
  write('Измененный массив: ');
  for i:= 1 to 5 do
    for j:= 1 to 10 do
    begin
      m[i, j]:= sqr(m[i, j]) * m[i, j];  //Возводим элемент массива в куб
      write('m[', i, ', ', j, '] = ', m[i, j], '  ');  //Печатаем элемент массива
    end;  //Конец цикла
  writeln;  //Перевод на новую строку
end;  //Конец процедуры

 

begin
  write('Исходный массив: ');
  for i:= 1 to 5 do
    for j:= 1 to 10 do
    begin
      m[i, j]:= random(40) - 20;  {Присваиваем элементу массива случайное значение из промежутка [-20, 20] }
      write('m[', i, ', ', j, '] = ', m[i, j], '  ');  //Печатаем элемент массива
    end;  //Конец цикла
  writeln;  //Перевод на новую строку
  CubeMas(m);  //Вызываем процедуру возведения в куб
end. //Конец программы

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота